What are the software requirements

All RebelBetting products are Windows-based and support Windows Vista, 7, 8 and 10.  You also require Microsoft Framework .NET version 4.5 or higher. If you’re running Windows 8 you already have this installed. If not, you will be asked to install during setup. You can also run RebelBetting products with other operative systems, like Mac

Also, make sure you use a computer with a stable and fast internet connection.